tt-flake/pkgs/buda-prebuilt/vendored/boost/default.nix
2024-11-01 00:21:03 +02:00

21 lines
393 B
Nix

{ lib
, callPackage
, boost-build
, fetchurl
}:
let
makeBoost = file:
lib.fix (self:
callPackage file {
boost-build = boost-build.override {
# useBoost allows us passing in src and version from
# the derivation we are building to get a matching b2 version.
useBoost = self;
};
}
);
in {
boost174 = makeBoost ./1.74.nix;
}